If you NEED to use a legacy version of an add-on. And can’t move away from the add-on, or don’t want to use Pale Moon or the other forks of Firefox; then keep on reading!

Currently the Ubuntu 18.04 PPA only has Firefox 60 ESR, so I opted to install the .deb from a 14.04 PPA. However, I expect the .deb to be removed some time in the future, so I archived it.

Here are the steps I took to install ESR 52.9:

  • Download everything needed:

Firefox ESR 52.9: https://launchpad.net/~jonathonf/+archive/ubuntu/firefox-esr/+build/15059457/+files/firefox-esr_52.9.0esr-1~14.04.york0_amd64.deb
libevent-2.0-5: http://security.ubuntu.com/ubuntu/pool/main/libe/libevent/libevent-2.0-5_2.0.21-stable-2ubuntu0.16.04.1_amd64.deb
libhunspell-1.3-0: http://mirrors.kernel.org/ubuntu/pool/main/h/hunspell/libhunspell-1.3-0_1.3.3-4ubuntu1_amd64.deb
libjsoncpp0: http://http.us.debian.org/debian/pool/main/libj/libjsoncpp/libjsoncpp0_0.6.0~rc2-3.1_amd64.deb
libvpx3: http://mirrors.kernel.org/ubuntu/pool/main/libv/libvpx/libvpx3_1.5.0-2ubuntu1_amd64.deb

You can download this with a single command in your terminal (copy and paste the whole thing):

mkdir firefox-esr_52-9_all-deb ; cd firefox-esr_52-9_all-deb ; wget https://launchpad.net/~jonathonf/+archive/ubuntu/firefox-esr/+build/15059457/+files/firefox-esr_52.9.0esr-1~14.04.york0_amd64.deb http://security.ubuntu.com/ubuntu/pool/main/libe/libevent/libevent-2.0-5_2.0.21-stable-2ubuntu0.16.04.1_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/h/hunspell/libhunspell-1.3-0_1.3.3-4ubuntu1_amd64.deb http://http.us.debian.org/debian/pool/main/libj/libjsoncpp/libjsoncpp0_0.6.0~rc2-3.1_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/libv/libvpx/libvpx3_1.5.0-2ubuntu1_amd64.deb

If some of the links are broken, then use the archive instead:

mkdir firefox-esr_52-9_all-deb ; cd firefox-esr_52-9_all-deb ; wget https://www.abqlug.com/downloads/firefox-esr_52-9_all-deb.tar.gz ; tar xvzf firefox-esr_52-9_all-deb.tar.gz
  • Removed firefox (without removing the existing profile)
sudo apt remove firefox.* iceweasel.*
  • Installed firefox-esr with the dependencies using dpkg
sudo dpkg -i lib* firefox-esr_52.9.0esr-1~14.04.york0_amd64.deb

And that should be it!

Troubleshooting:

If you receive this error:
dpkg-divert: error: ‘diversion of /usr/bin/firefox to /usr/bin/firefox.real by firefox-esr’ clashes with ‘diversion of /usr/bin/firefox to /usr/bin/_neon.firefox by neon-settings’

Then run this:

sudo dpkg-divert --remove /usr/bin/firefox

If you are done with using Firefox ESR 52, run this command to uninstall it:

sudo apt remove firefox-esr

If you cannot download the .deb(s) from the links above, here is the archive: https://www.abqlug.com/downloads/firefox-esr_52-9_all-deb.tar.gz

If you would rather install directly from Mozilla, you might want to look at compiling from source. I didn’t cover that here. But you may want to give it a shot. Here is the link for the source code. https://archive.mozilla.org/pub/firefox/releases/52.9.0esr/linux-x86_64/en-US/firefox-52.9.0esr.tar.bz2

How to install Firefox ESR 52.9 on Ubuntu 18.04
Tagged on:         

Leave a Reply

Your email address will not be published. Required fields are marked *